Getting php w/libmcrypt to compile

lad to Just a quick note I thought I would drop to anybody who is having this error popup when trying to compile PHP:

[quote]/usr/libexec/elf/ld: cannot find -lltdl[/quote]

If you want to fix that error all you really need to do is go back into your source tree for libmcrypt. and execute the following commands:

 
cd libmcrypt-2.5.7
cd libltdl
./configure
--enable-ltdl-install
make
make install

turns out that FreeBSD porting process doesn’t do this for you. I also am hearing word that not many if any of the automated packaging systems do this. So, hopefully I saved somebody out there a headache :P

G

Share
This entry was posted in PHP. Bookmark the permalink.

4 Responses to Getting php w/libmcrypt to compile

  1. Simon says:

    You saved me a headache. Thanks. You may want to change
    ./configure –enable-ltld-install
    to
    ./configure –enable-ltdl-install

  2. mike.lively says:

    Glad I could help.

    Thanks for the heads up about the typo. I fixed that and also edited so those commands don’t all show up on the same line.

    Next time maybe I’ll double check an entry after I post :P :D

  3. Patrik says:

    Thanks alot! I have been struggling with this for a few hours now and finally I googled your answer. Thanks man!

  4. Aaron Newton says:

    Successfully compiling libmcrypt seems to solve a dependancy issue when attempting to configure/make PHP, namely:

    “configure: error: mcrypt.h not found. Please reinstall libmcrypt.”

    This seems to be a very common issue, so I thought it was worth mentioning. PHP compiled smoothly after I ran this.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>